CSN Login
Members Online: 5

You are here

Ureteroscopy&Biopsy

joshuarivas1969
Posts: 5
Joined: Jan 2021

Good Morning all, 

I had my ureteroscopy and Biopsy on 2/11/2021 and 5 days later I am still in a lot of pain. They have left a stent in, could this be why?  Has anyone here had this procedure done and if so, what was your experience with it.  Trying to figure out if this is normal for this procedure. Thank you in advance for any insight you may be able to give me.  

icemantoo's picture
icemantoo
Posts: 3334
Joined: Jan 2010

my league.

 

 

 

 

icemantoo

AliceB1950's picture
AliceB1950
Posts: 113
Joined: Jun 2019

Sorry, but I don't know what that procedure is. Is it a diagnostic procedure for kidney cancer? If so, I didn't have anything like that, just scans to find mine. I hope you feel better soon.

donna_lee's picture
donna_lee
Posts: 1003
Joined: Feb 2009

But I can empathasize with you.  Urethroscopy only goes from the outside into the bladder. And then, ureters drain each kidney into the bladder.  Ouch.  Even though you're scheduled for surgery, you need to call whoever did the tests to find out why the pain or if it is "normal", and to find out the results of the biopsy.

Keep us posted.

donna_lee

NelsJenn
Posts: 1
Joined: May 2021

Dear Joshuarivas1969 and everyone, I just joined and recently had a ureteroscopy, so this message might be obsolete. My ureteroscopy was only painful for 3 days at the most. I had blood in my urine for around five days, with the first three days of moderate blook which tapered off by the fifth day. Best, nelsjenn

Subscribe to Comments for "Ureteroscopy&Biopsy"