CSN Login
Members Online: 6

You are here

Urine testing

daisybud's picture
daisybud
Posts: 440
Joined: Jan 2016

I've had higher (+2) leukocyte esterase and wbc (10-20) with urine tests the last several times.  I did have one cultured and no bacteria in urine. Nobody seems concerned when I ask.  Although, when I look it up I see can mean infection which I don't have or could be sign of kidney or bladder cancer. Anyone have any knowledge or experience with this issue?

Thanks Kim 

todd121's picture
todd121
Posts: 1422
Joined: Dec 2012

There are no blood tests that I'm aware of that indicate kidney cancer. You have to have a CT to rule it in/out (or some other imaging). Some of us had visible blood in our urine and pain and that was our main symptom. Others had imaging for other reasons and it got caught.

I've never heard of anyone having these symptoms on here and it being an indication of kidney cancer.

You should see a urologist. They will know and order more tests if you need them.

Todd

Bay Area Guy's picture
Bay Area Guy
Posts: 374
Joined: Jun 2016

Same as Todd.  The only thing a urine test did for me was to uncover some microscopic blood, which led my primary to have me go for a CT scan and that scan uncovered the small lesion on my kidney.  Since it was so small, I had active surveillance on the lesion for 2-1/2 years before the docs determined it was, in fact, malignant.  What's odd is in that 2-1/2 years, I had a few more urine tests (I have one every year with my annual physical) and none of the other tests showed any traces of blood.  I'm convinced that my parents (who had passed away 2 and 3 years earlier) noticed that I had the lesion and caused the microscopic blood in the urine.  Yeah, I know it's pretty unlikely, but I have no other explanation for it.

daisybud, get a referral to a urologist to get your situation figured out.

daisybud's picture
daisybud
Posts: 440
Joined: Jan 2016

I was Ned this July withUS and chest xray.  Ct Ned in January 2018.  Just can't get answers on why the urine test is always a little high on those two items. Again shows no Infection.  Will ask again at my next appt.  

Thanks  

Subscribe to Comments for "Urine testing"